summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-12 18:26:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:35 +0200
commit558fe17c53a009ca177b78f9160c0f9552193ae0 (patch)
treec31dc34f6d493198bb9fdcb11c6deb9dc6fda8b3 /gnu/packages
parente2178738c628f96f07b699dbd4329fe86c426ed4 (diff)
gnu: Add texlive-showexpl.
* gnu/packages/tex.scm (texlive-showexpl): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 585e55b369..b55953f47f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5566,6 +5566,32 @@ numbers. While the package may obviously be used to typeset DNA sequences, the
user may consider the @code{dnaseq} as a rather more powerful alternative.")
(license license:lppl1.3+)))
+(define-public texlive-showexpl
+ (package
+ (name "texlive-showexpl")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/showexpl/" "source/latex/showexpl/"
+ "tex/latex/showexpl/")
+ (base32
+ "0vff1yk7a3f4csxibfk6r37s3h6n4wdpnk3qj4dsx7kh5zrcysha")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-attachfile
+ texlive-latex-float
+ texlive-graphics
+ texlive-listings
+ texlive-refcount
+ texlive-latex-varwidth))
+ (home-page "https://ctan.org/pkg/showexpl")
+ (synopsis "Typesetting LaTeX source code")
+ (description
+ "This package provides a way to typeset LaTeX source code and the related
+result in the same document.")
+ (license license:lppl1.2+)))
+
(define-public texlive-latex-stackengine
(package
(inherit (simple-texlive-package