summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-12 18:25:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:34 +0200
commit5d60e272c94825704bcc60ba3c65e7ff30a328c4 (patch)
treed72a5d383ff86bd20811856173095ddb17577448 /gnu/packages
parent4ab1b5ccd4dd20d3768f200812234599e0a0843c (diff)
gnu: Add texlive-multido.
* gnu/packages/tex.scm (texlive-multido): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7ea7af985d..5b9cdde813 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7246,6 +7246,28 @@ in the form @code{key=value} are available, for example:
(define-deprecated-package texlive-latex-enumitem texlive-enumitem)
+(define-public texlive-multido
+ (package
+ (name "texlive-multido")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/multido/"
+ "source/generic/multido/"
+ "tex/generic/multido/" "tex/latex/multido/")
+ (base32
+ "1vwf2naw5bgs93s2gcmf226f60ws9z6cmw6gi1562fs8vg4mnjsh")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/multido")
+ (synopsis "Loop facility for Generic TeX")
+ (description
+ "The package provides the @code{\\multido} command, which was originally
+designed for use with PSTricks. Fixed-point arithmetic is used when working
+on the loop variable, so that the package is equally applicable in graphics
+applications like PSTricks as it is with the more common integer loops.")
+ (license license:lppl)))
+
(define-public texlive-latex-multirow
(package
(name "texlive-latex-multirow")