summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-06 12:02:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:32 +0200
commit69b1df59e3379935538cf0737b038fa31088c71c (patch)
tree69174f2bbefad807718c8799dd9070c50b81c561 /gnu/packages
parent14cd6c2fb4b826869f5f3fa48bbfc581114a6478 (diff)
gnu: Add texlive-passivetex.
* gnu/packages/tex.scm (texlive-passivetex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9c92c99af8..32a2f624b1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4534,6 +4534,35 @@ T2* and X2 encodings. These encodings cover (between them) pretty much every
language that is written in a Cyrillic alphabet.")
(license license:lppl1.3c+)))
+(define-public texlive-passivetex
+ (package
+ (name "texlive-passivetex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "tex/xmltex/passivetex/")
+ (base32
+ "1h49v6sqbm27isfwwcql9dzxn4vmcn2algkqh7f1pzj860xw3ygn")))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-amsfonts
+ texlive-graphics
+ texlive-hyperref
+ texlive-marvosym
+ texlive-psnfss
+ texlive-tipa
+ texlive-times
+ texlive-tools
+ texlive-ulem
+ texlive-url))
+ (home-page "https://ctan.org/pkg/passivetex")
+ (synopsis "Support package for XML/SGML typesetting")
+ (description
+ "This is a set of packages providing XML parsing, UTF-8 parsing,
+Unicode entities, and common formatting object definitions for JadeTeX.")
+ ;; License given in "tex/xmltex/passivetex/mlnames.sty".
+ (license license:lppl1.0+)))
+
(define-public texlive-pict2e
(let ((template (simple-texlive-package
"texlive-pict2e"