summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-05-04 21:50:37 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-08-25 14:35:22 +0200
commit6c447ababfb11581a75cff8281e96f701e216692 (patch)
treeed91d00f84af320ce62e1a5538855065e33d2def /gnu/packages
parent106ad23ae44c34f275b8857cfdac2356d5962e6a (diff)
gnu: gcc-toolchain: Add empty librt.a.
* gnu/packages/commencememnt.scm (make-gcc-toolchain): Add empty librt.a. * gnu/packages/base.scm (gcc): Add a warning regarding the missing librt.a.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/base.scm4
-rw-r--r--gnu/packages/commencement.scm7
2 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 32bc69e2c4..5a3d5aced5 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -967,6 +967,10 @@ the store.")
;; library is empty by some criterion (such as their file
;; size equaling eight bytes) rather than hardcoding them
;; by name.
+
+ ;; XXX: We forgot librt.a for the current version! In
+ ;; the meantime, gcc-toolchain provides it, but remove
+ ;; that fix once librt.a is added here.
(define empty-static-libraries
'("libpthread.a" "libdl.a" "libutil.a" "libanl.a"))
(define (empty-static-library? file)
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index e522e70444..9604f06a47 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3561,6 +3561,13 @@ COREUTILS-FINAL vs. COREUTILS, etc."
(union-build (assoc-ref %outputs "static")
(list (assoc-ref %build-inputs
"libc-static")))
+ ;; XXX Remove once an empty librt.a is added to
+ ;; libc:out.
+ (copy-file
+ (string-append (assoc-ref %outputs "out")
+ "/lib/libpthread.a")
+ (string-append (assoc-ref %outputs "out")
+ "/lib/librt.a"))
#t))))
(native-search-paths