summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-11-06 12:06:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-13 15:00:48 +0100
commit77025bd51139c74d572299f4b7b33e071cd54cd8 (patch)
tree4c6c1022f2dbf791e75b400263126f0b89f8640b /gnu/packages
parent4e1c6f499880e867d162dacff32c59635e675dbf (diff)
gnu: Add r-basicstarrseq.
* gnu/packages/bioconductor.scm (r-basicstarrseq): New variable. Change-Id: I88f314877ea4ab98976820a4acc337ae3a34e604
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3955f04bf1..cf7e1c07ac 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -22672,6 +22672,41 @@ Additionally, BASiCS can compare gene expression patterns between two or more
pre-specified groups of cells.")
(license license:gpl3)))
+(define-public r-basicstarrseq
+ (package
+ (name "r-basicstarrseq")
+ (version "1.30.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BasicSTARRseq" version))
+ (sha256
+ (base32 "1dw6bv1qk2bn0l3m458sqgvm3s1karh4n3431pl7r0jj2r3mr6xa"))))
+ (properties `((upstream-name . "BasicSTARRseq")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-genomeinfodb
+ r-genomicalignments
+ r-genomicranges
+ r-iranges
+ r-s4vectors))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/BasicSTARRseq")
+ (synopsis "Basic peak calling on STARR-seq data")
+ (description
+ "This package implements a method that aims to identify enhancers on
+large scale. The STARR-seq data consists of two sequencing datasets of the
+same targets in a specifc genome. The input sequences show which regions
+where tested for enhancers. Significant enriched peaks i.e. a lot more
+sequences in one region than in the input where enhancers in the genomic DNA
+are, can be identified. So the approach pursued is to call peak every region
+in which there is a lot more
+(significant in a binomial model) STARR-seq signal than input signal and
+propose an enhancer at that very same position. Enhancers then are called
+weak or strong dependent of there degree of enrichment in comparison to
+input.")
+ (license license:lgpl3)))
+
(define-public r-basilisk-utils
(package
(name "r-basilisk-utils")