summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2023-07-14 22:18:35 -0400
committer宋文武 <iyzsong@member.fsf.org>2023-07-20 19:09:43 +0800
commita74604c0f095b665de5ca0bd4b54b620484c2f97 (patch)
tree050dffccb38039685b2146073035cd9c3c3ca311 /gnu/packages
parentf019ce027c280a7eb286c66a956ed8a5330a831c (diff)
gnu: Add wdisplays.
* gnu/packages/wm.scm (wdisplays): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b9909de219..5c614be735 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2022,6 +2022,29 @@ automatically enabled and disabled on hotplug. Kanshi can be used with
Wayland compositors supporting the wlr-output-management protocol.")
(license license:expat))) ; MIT license
+(define-public wdisplays
+ (package
+ (name "wdisplays")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artizirk/wdisplays.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06ydcmfdics2qqjb14p767xs8khd86nancdd9z8j11h2gpvwznvn"))))
+ (build-system meson-build-system)
+ (inputs (list gtk+ libepoxy wayland))
+ (native-inputs (list `(,glib "bin") pkg-config))
+ (home-page "https://github.com/artizirk/wdisplays")
+ (synopsis "Configuring displays in Wayland compositors")
+ (description "@command{wdisplays} is a graphical application for
+configuring displays in Wayland compositors that implements the
+wlr-output-management-unstable-v1 protocol.")
+ (license license:gpl3+)))
+
(define-public stumpwm
(package
(name "stumpwm")