summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-09 23:06:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:27 +0200
commitab95125765245c1e3bf2ede3a71da1eb3602e1e5 (patch)
treec23047db471769dc185c6c841e83fe8b168157ef /gnu/packages
parent1cca15cf732c27ef0f1804ec9854b20f3b5dc844 (diff)
gnu: texlive-latex-trimspaces -> texlive-trimspaces.
* gnu/packages/tex.scm (texlive-trimspaces): New variable. (texlive-latex-trimspaces): (texlive-pstool): * gnu/packages/python-xyz.scm (python-nbconvert):
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/tex.scm56
2 files changed, 30 insertions, 28 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 973216c5ed..575e2b8d81 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15191,7 +15191,7 @@ time.")
texlive-latex-jknapltx
texlive-ms
texlive-latex-parskip
- texlive-latex-trimspaces
+ texlive-trimspaces
texlive-latex-upquote
texlive-stringenc
texlive-tcolorbox
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a83e7ac5b9..e18c618f47 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5234,8 +5234,8 @@ rotated.")
texlive-l3kernel ; for expl3
texlive-oberdiek
texlive-latex-psfrag
- texlive-tools ; for shellesc
- texlive-latex-trimspaces
+ texlive-tools ; for shellesc
+ texlive-trimspaces
texlive-latex-xkeyval))
(home-page "https://www.ctan.org/pkg/pstool")
(synopsis "Process PostScript graphics within pdfLaTeX documents")
@@ -5354,40 +5354,42 @@ and the ability to create new ‘List of ...’. The ToC @code{\\parskip} may
be changed.")
(license license:lppl1.3c+)))
-(define-public texlive-latex-trimspaces
+(define-public texlive-trimspaces
(package
- (name "texlive-latex-trimspaces")
+ (name "texlive-trimspaces")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "trimspaces"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0da00lb32am4g63mn96625wg48p3pj3spx79lajrk17d549apwqa"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/trimspaces/"
+ "source/latex/trimspaces/"
+ "tex/latex/trimspaces/")
+ (base32
+ "0if7pqaib533fbrj9r62mmr4h012hrpszdxs759rwhmyycikg6dk")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
(arguments
- '(#:tex-directory "latex/trimspaces"
- #:tex-format "latex"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-bug
- (lambda _
- ;; The "ins" file refers to the wrong source file.
- (substitute* "trimspaces.ins"
- (("pstool.tex") "trimspaces.tex"))
- #t)))))
- (inputs
+ (list
+ #:tex-format "latex"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-bug
+ (lambda _
+ ;; The "ins" file refers to the wrong source file.
+ (substitute* "source/latex/trimspaces/trimspaces.ins"
+ (("pstool\\.tex") "trimspaces.tex")))))))
+ (propagated-inputs
(list texlive-filecontents))
- (home-page "https://www.ctan.org/pkg/trimspaces")
+ (home-page "https://ctan.org/pkg/trimspaces")
(synopsis "Trim spaces around an argument or within a macro")
(description
- "This very short package allows you to expandably remove spaces around a
-token list (commands are provided to remove spaces before, spaces after, or
-both); or to remove surrounding spaces within a macro definition, or to define
-space-stripped macros.")
+ "This package provides a very short package that allows you to expandably
+remove spaces around a token list (commands are provided to remove spaces
+before, spaces after, or both); or to remove surrounding spaces within a macro
+definition, or to define space-stripped macros.")
(license license:lppl)))
+(define-deprecated-package texlive-latex-trimspaces texlive-trimspaces)
+
(define-public texlive-calrsfs
(package
(inherit