summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-12 18:38:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:35 +0200
commitb02b841390866bc262f80136d2eb590484b19184 (patch)
tree6978f0046bb02f373c17fa4c4fb29ce38e1c7ed1 /gnu/packages
parent558fe17c53a009ca177b78f9160c0f9552193ae0 (diff)
gnu: Add texlive-subfig.
* gnu/packages/tex.scm (texlive-subfig): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b55953f47f..be5072b9a4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7554,6 +7554,33 @@ the whole font.")
(define-deprecated-package texlive-fonts-stmaryrd texlive-stmaryrd)
+(define-public texlive-subfig
+ (package
+ (name "texlive-subfig")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/subfig/" "source/latex/subfig/"
+ "tex/latex/subfig/")
+ (base32
+ "0bq1328pb1ak91j7q8n1kh2fncr742lvff7apgf8kkxzxjfg2z9r")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-caption
+ texlive-graphics))
+ (home-page "https://ctan.org/pkg/subfig")
+ (synopsis "Figures broken into subfigures")
+ (description
+ "The package provides support for the manipulation and reference of small
+or sub figures and tables within a single figure or table environment. It is
+convenient to use this package when your subfigures are to be separately
+captioned, referenced, or are to be included in the List-of-Figures. A new
+@code{\\subfigure} command is introduced which can be used inside a figure
+environment for each subfigure. An optional first argument is used as the
+caption for that subfigure.")
+ (license license:lppl)))
+
(define-public texlive-subfigure
(let ((template (simple-texlive-package
"texlive-subfigure"