summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 11:52:45 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 12:22:16 +0100
commitc63566c5cfe622575637530227169f7d40c2422a (patch)
treec422c1eb648451c1505dcc1c26956e31485bed88 /gnu/packages
parent09deb8a570f205b198af65bcbe22c716b5677dc3 (diff)
gnu: texlive-latex-refcount: Rename to texlive-refcount.
* gnu/packages/tex.scm (texlive-refcount): New variable. (texlive-latex-refcount): Deprecated alias. (texlive-hyperref): * gnu/packages/docbook.scm (dblatex): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/tex.scm54
2 files changed, 40 insertions, 16 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index c0f7dfd750..44749e2c5c 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -477,7 +477,7 @@ the in DocBook SGML DTDs.")
texlive-latex-multirow
texlive-latex-overpic
texlive-latex-pdfpages
- texlive-latex-refcount
+ texlive-refcount
texlive-latex-subfigure
texlive-latex-titlesec
texlive-wasysym
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9204081c86..588d240947 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3520,7 +3520,7 @@ XML, using UTF-8 or a suitable 8-bit encoding.")
texlive-latex-kvoptions
texlive-letltxmacro
texlive-pdftexcmds
- texlive-latex-refcount
+ texlive-refcount
texlive-latex-rerunfilecheck
texlive-url))
(home-page "https://www.ctan.org/pkg/hyperref")
@@ -5025,24 +5025,48 @@ re-processing.")
(define-deprecated-package texlive-latex-pstool texlive-pstool)
-(define-public texlive-latex-refcount
- (package
- (inherit (simple-texlive-package
- "texlive-latex-refcount"
- (list "/doc/latex/refcount/"
- "/tex/latex/refcount/")
- (base32
- "0pkmqj2qihndlv3ks33xzqw91q46jx79r3aygj68d8dflyddi583")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/refcount")
- (synopsis "Counter operations with label references")
- (description
- "This package provides the @code{\\setcounterref} and
+(define-public texlive-refcount
+ (let ((template (simple-texlive-package
+ "texlive-refcount"
+ (list "doc/latex/refcount/"
+ "source/latex/refcount/"
+ "tex/latex/refcount/")
+ (base32
+ "128cvwdl4wcdshvs59yn5iljdxxdrc5jircbxav77y7kc3l33z7z"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/refcount")
+ ((#:build-targets _ '())
+ #~(list "refcount.dtx"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/latex/refcount")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (home-page "https://www.ctan.org/pkg/refcount")
+ (synopsis "Counter operations with label references")
+ (description
+ "This package provides the @code{\\setcounterref} and
@code{\\addtocounterref} commands which use the section (or other) number
from the reference as the value to put into the counter. It also provides
@code{\\setcounterpageref} and @code{\\addtocounterpageref} that do the
corresponding thing with the page reference of the label.")
- (license license:lppl1.3c+)))
+ (license license:lppl1.3c+))))
+
+(define-deprecated-package texlive-latex-refcount texlive-refcount)
(define-public texlive-seminar
(package