summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-02 20:53:31 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commitc7303d3cef71dbe7fad2d082126e787a4385c765 (patch)
tree92579cea247e0433ddd35583955ea8d5481a5ebc /gnu/packages
parentb50c5b741891eabb16b83091d911c6ebd9b890d3 (diff)
gnu: Add python-exif-read.
* gnu/packages/python.scm (python-exif-read, python2-exif-read): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 641a5dfc67..17147b96bc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -968,3 +968,30 @@ technique that encourages collaboration between developers, QA and
non-technical or business participants in a software project. Behave uses
tests written in a natural language style, backed up by Python code.")
(license x11)))
+
+(define-public python-exif-read
+ (package
+ (name "python-exif-read")
+ (version "1.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://pypi.python.org/packages/source/E/ExifRead/ExifRead-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "17c627gcdmyc05hz4zk8qs4pjgw6rc68qzjzgz8gh1cmpsd7acf1"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (arguments `(#:tests? #f)) ; no tests
+ (home-page "https://github.com/ianare/exif-py")
+ (synopsis "Python library to extract EXIF data from image files")
+ (description
+ "ExifRead is a Python library to extract EXIF data from tiff and jpeg
+files.")
+ (license bsd-3)))
+
+(define-public python2-exif-read
+ (package-with-python2 python-exif-read))