summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-12 18:34:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:35 +0200
commite2178738c628f96f07b699dbd4329fe86c426ed4 (patch)
tree0d4a3128cdb277bb19abc2dba47efb2e0d0d739c /gnu/packages
parent5d60e272c94825704bcc60ba3c65e7ff30a328c4 (diff)
gnu: Add texlive-attachfile.
* gnu/packages/tex.scm (texlive-attachfile): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5b9cdde813..585e55b369 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3220,6 +3220,36 @@ with the required packages, constitutes what every LaTeX distribution should
contain.")
(license license:lppl1.3c+))))
+(define-public texlive-attachfile
+ (package
+ (name "texlive-attachfile")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bib/attachfile/"
+ "doc/latex/attachfile/"
+ "source/latex/attachfile/"
+ "tex/latex/attachfile/")
+ (base32
+ "0340c4rvxhhk95wlhf54n9akiwhj6pj0bslys6bkq29x9903zx5h")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-graphics
+ texlive-hyperref
+ texlive-iftex))
+ (home-page "https://ctan.org/pkg/attachfile")
+ (synopsis "Attach arbitrary files to a PDF document")
+ (description
+ "Starting with PDF 1.3, PDF files can contain file attachments, i.e.,
+arbitrary files that a reader can extract, just like attachments to an e-mail
+message. The @code{attachfile} package brings this functionality to pdfLaTeX
+and provides some additional features such as the ability to use arbitrary
+LaTeX code for the file icon. Settings can be made either globally or on
+a per-attachment basis. @code{attachfile} makes it easy to attach files and
+customize their appearance in the enclosing document.")
+ (license license:lppl1.3+)))
+
(define-public texlive-atveryend
(let ((template (simple-texlive-package
"texlive-atveryend"