summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-02 21:22:43 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commite6cfbd364a16e372b036cba73c0f94e9c24933c6 (patch)
tree17dba08982a81ccf7cd440adddcb34b3c10d9359 /gnu/packages
parent3a1f9a68e5c75097f94f193f96350db97723f027 (diff)
gnu: Add python2-requests.
* gnu/packages/python.scm (python2-requests): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 766ce16551..5562ed1a28 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1048,3 +1048,29 @@ is used by the Requests library to verify HTTPS requests.")
(define-public python2-certifi
(package-with-python2 python-certifi))
+
+(define-public python2-requests
+ (package
+ (name "python2-requests")
+ (version "2.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://pypi.python.org/packages/source/r/requests/requests-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gknlfx1wakrrm1zi8gi03x2lzj4dsns0vjw0nsmgqvkphyf01vh"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-certifi" ,python-certifi)))
+ (arguments `(#:tests? #f ; no tests
+ #:python ,python-2))
+ (home-page "http://python-requests.org/")
+ (synopsis "Python HTTP library")
+ (description
+ "Requests is a Python HTTP client library. It aims to be easier to use
+than Python’s urllib2 library.")
+ (license asl2.0)))