summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-02 19:23:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-02 19:23:51 +0100
commite8814809c2de6fe2f23169775207b3d2e537724f (patch)
tree934f48f6c1fb1cf5f59ed296efd2641c8aac33e0 /gnu/packages
parent5b030de3866f450209f39079abe63a5fbcb719a0 (diff)
gnu: Add r-toast.
* gnu/packages/bioconductor.scm (r-toast): New variable. Change-Id: I922508bce0bdf0304e2f40d93a63ffdb58d03aa6
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 72a0fe377f..1ea5e47321 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10867,6 +10867,44 @@ identifier translation via the GDC API.")
"This package implements widgets to provide user interfaces.")
(license license:artistic2.0)))
+(define-public r-toast
+ (package
+ (name "r-toast")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "TOAST" version))
+ (sha256
+ (base32 "00wpgs2zdrgrh9xmp6m5h9xgv85mhdi36qvwg9gwbz9i7cfabmy1"))))
+ (properties `((upstream-name . "TOAST")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-corpcor
+ r-doparallel
+ r-epidish
+ r-ggally
+ r-ggplot2
+ r-limma
+ r-nnls
+ r-quadprog
+ r-summarizedexperiment
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/TOAST")
+ (synopsis "Tools for the analysis of heterogeneous tissues")
+ (description
+ "This package is devoted to analyzing high-throughput data (e.g. gene
+expression microarray, DNA methylation microarray, RNA-seq) from complex
+tissues. Current functionalities include
+
+@enumerate
+@item detect cell-type specific or cross-cell type differential signals
+@item tree-based differential analysis
+@item improve variable selection in reference-free deconvolution
+@item partial reference-free deconvolution with prior knowledge.
+@end enumerate")
+ (license license:gpl2)))
+
;; TODO: check javascript
(define-public r-trackviewer
(package