summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-27 20:31:38 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 21:30:03 +0200
commite944734ef9afa1ac9b46579934482b7d909ed24e (patch)
tree3264c818aa7f37fb5ca3b9cd1b12687f464ffc6f /gnu/packages
parent6ef998d54e57c8969bc3db7888fb7d4939a6fa83 (diff)
build-system/pyproject: Always run tests verbosely for supported backends.
* guix/build-system/pyproject.scm (pyproject-build): Default to '() instead of #false for TEST-FLAGS. * guix/build/pyproject-build-system.scm (check): Unconditionally enable verbose test flags. * doc/guix.texi (Build Systems): Document this change. * gnu/packages/fontutils.scm (python-glyphslib)[arguments]: Remove verbosity from #:test-flags. * gnu/packages/pdf.scm (python-pydyf, weasyprint)[arguments]: Likewise. * gnu/packages/python-web.scm (python-openapi-spec-validator)[arguments]: Likewise. * gnu/packages/python-xyz.scm (python-path, python-tempora)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/fontutils.scm3
-rw-r--r--gnu/packages/pdf.scm4
-rw-r--r--gnu/packages/python-web.scm2
-rw-r--r--gnu/packages/python-xyz.scm4
4 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index df3774e977..368aad49d6 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -598,8 +598,7 @@ process. FontParts is the successor of RoboFab.")
(build-system pyproject-build-system)
(arguments
(list
- #:test-flags #~'("-vv"
- ;; These fail because the test data has not yet been
+ #:test-flags #~'(;; These fail because the test data has not yet been
;; updated for newer FontTools:
;; https://github.com/googlefonts/glyphsLib/issues/787
;; Re-enable for versions > 6.0.7.
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 95cc3b1e22..070dc59ac0 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -739,7 +739,7 @@ extracting content or merging files.")
(build-system pyproject-build-system)
(arguments
(list
- #:test-flags #~'("-vv" "-c" "/dev/null")))
+ #:test-flags #~'("-c" "/dev/null")))
(propagated-inputs (list python-pillow))
(native-inputs
(list ghostscript
@@ -1500,7 +1500,7 @@ manipulating PDF documents from the command line. It supports
(build-system pyproject-build-system)
(arguments
(list
- #:test-flags #~(list "-vv" "-c" "/dev/null"
+ #:test-flags #~(list "-c" "/dev/null"
"-n" (number->string (parallel-job-count)))
#:phases
#~(modify-phases %standard-phases
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cbc515fc64..59d677ca35 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1648,7 +1648,7 @@ JSON Schema Specification Draft 2020-12.
(list
;; The example tests attempt to fetch resources from the Internet
;; (see: https://github.com/p1c2u/openapi-spec-validator/issues/151).
- #:test-flags #~'("-vv" "-k" "not Example and not Exampe")
+ #:test-flags #~'("-k" "not Example and not Exampe")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'remove-coverage-pytest-options
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 18089d090e..1c2f9d7b73 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12753,7 +12753,7 @@ invoked on those path objects directly.")
((#:tests? _ #f)
(not (%current-target-system)))
((#:test-flags flags #~'())
- #~(append (list "-vv" "-k"
+ #~(append (list "-k"
(string-append
;; Do not test the myproject.toml build as it tries
;; to pull dependencies from the Internet.
@@ -21366,7 +21366,7 @@ particularly convenient for use in tests.")
(arguments
;; Do not test the myproject.toml build as it tries to pull
;; dependencies from the Internet.
- (list #:test-flags #~'("-vv" "-k" "not project")))
+ (list #:test-flags #~'("-k" "not project")))
(native-inputs
(list python-freezegun
python-pytest