summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-05 18:43:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:29 +0200
commitf380aa35608c0920998a0c7e8af4bdd9dbf98db3 (patch)
tree7ab072179bdc5831656524c8303db0a82d7a43da /gnu/packages
parent92c0962c5a69185decc30ba91b520b208ef45d21 (diff)
gnu: Add texlive-minitoc.
* gnu/packages/tex.scm (texlive-minitoc): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3d98f658d3..9817e32567 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10264,6 +10264,30 @@ various fonts are provided. An alternative package
the bundle.")
(license license:lppl1.3c))))
+(define-public texlive-minitoc
+ (package
+ (name "texlive-minitoc")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/minitoc/"
+ "tex/latex/minitoc/")
+ (base32
+ "0yd1na5b9m7z1j87a5fjwjqddfpiblfbpzcv0vlvql6lwh38mii7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/minitoc")
+ (synopsis "Produce a table of contents for each chapter, part or section")
+ (description
+ "The @code{minitoc} package allows you to add
+mini-tables-of-contents (minitocs) at the beginning of every chapter, part or
+section. There is also provision for mini-lists of figures and of tables. At
+the part level, they are parttocs, partlofs and partlots. If the type of
+document does not use chapters, the basic provision is section level secttocs,
+sectlofs and sectlots. The package has provision for language-specific
+configuration of its own fixed names, using @file{.mld} files.")
+ (license license:lppl1.3+)))
+
(define-public texlive-minted
(let ((template (simple-texlive-package
"texlive-minted"