summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-13 23:58:18 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-14 00:08:30 +0100
commit970b7a949dcdef7c0709acc0cd54426a654a1490 (patch)
treed00f44b2841d7bbab8b4fa02c104e9d8db65e058 /gnu/packages
parentf833399811555a13756aa64bb0aaaaafab79ee99 (diff)
gnu: Add texlive-graphics.
* gnu/packages/tex.scm (texlive-graphics): New variable. (texlive-latex-graphics): Deprecate variable. (texlive-base): (texlive-pstool): (texlive-jadetex): * gnu/packages/bioinformatics.scm (velvet): * gnu/packages/plotutils.scm (asymptote): * gnu/packages/python-xyz.scm (python-numpy-documentation): (python-ipython-documentation): * gnu/packages/radio.scm (gnuradio): (libosmo-dsp): * gnu/packages/statistics.scm (r-with-tests): Use new variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/plotutils.scm2
-rw-r--r--gnu/packages/python-xyz.scm4
-rw-r--r--gnu/packages/radio.scm4
-rw-r--r--gnu/packages/statistics.scm2
-rw-r--r--gnu/packages/tex.scm75
6 files changed, 58 insertions, 31 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c7761544b0..6df3f8380f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13375,7 +13375,7 @@ to an artifact/contaminant file.")
(inputs
(list openmpi zlib))
(native-inputs
- `(("texlive" ,(texlive-updmap.cfg (list texlive-latex-graphics
+ `(("texlive" ,(texlive-updmap.cfg (list texlive-graphics
texlive-fonts-ec
texlive-hyperref)))))
(home-page "https://www.ebi.ac.uk/~zerbino/velvet/")
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 75ac1efd06..afb1129abc 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -301,7 +301,7 @@ colors, styles, options and details.")
texlive-hyperref
texlive-latex-base
texlive-latex-geometry
- texlive-latex-graphics
+ texlive-graphics
texlive-latex-kvoptions
texlive-latex-media9
texlive-oberdiek ;for ifluatex
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b09d366e71..dafda261cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5846,7 +5846,7 @@ readable format.")
texlive-latex-float
texlive-latex-framed
texlive-latex-geometry
- texlive-latex-graphics
+ texlive-graphics
texlive-hyperref
texlive-latex-mdwtools
texlive-latex-multirow
@@ -8931,7 +8931,7 @@ computing.")
texlive-latex-float
texlive-latex-framed
texlive-latex-geometry
- texlive-latex-graphics
+ texlive-graphics
texlive-hyperref
texlive-latex-mdwtools
texlive-latex-multirow
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index bba064c672..ccfa77850b 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -497,7 +497,7 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-latex-amsmath
;; TODO: Add newunicodechar.
- texlive-latex-graphics)))
+ texlive-graphics)))
("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -705,7 +705,7 @@ to access different radio hardware.")
("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-latex-amsmath
;; TODO: Add newunicodechar.
- texlive-latex-graphics)))))
+ texlive-graphics)))))
(inputs
(list fftwf))
(arguments
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 7fa31c59b4..fbb7a594ed 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -352,7 +352,7 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
texlive-amsfonts
texlive-latex-base
texlive-latex-fancyvrb
- texlive-latex-graphics
+ texlive-graphics
texlive-hyperref
texlive-oberdiek
texlive-latex-tools
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 837cb886f9..57aa00491f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3245,29 +3245,56 @@ packages.")
set default \"driver\" options for the color and graphics packages.")
(license license:public-domain)))
-(define-public texlive-latex-graphics
- (package
- (name "texlive-latex-graphics")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "graphics"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0fgjl58f25zvagssz4dwmmsclzw8cr7mx00kdrbx2kcnamcb7h8d"))))
- (build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/graphics"))
- (propagated-inputs
- (list texlive-graphics-cfg texlive-graphics-def))
- (home-page "https://www.ctan.org/pkg/latex-graphics")
- (synopsis "LaTeX standard graphics bundle")
- (description
- "This is a collection of LaTeX packages for producing color, including
-graphics (e.g. PostScript) files, and rotation and scaling of text in LaTeX
+(define-public texlive-graphics
+ (let ((template (simple-texlive-package
+ "texlive-graphics"
+ (list "doc/latex/graphics/"
+ "source/latex/graphics/"
+ "tex/latex/graphics/")
+ (base32
+ "0prw1zcv4fcj3zg0kyhj0k7ax0530adl60bajzvbv3fi16d7rqlq"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/graphics")
+ ((#:build-targets _ '())
+ #~(list "graphics-drivers.ins" "graphics.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/latex/graphics")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc)
+ ;; This file is not generated from the sources.
+ (install-file
+ (string-append
+ origin
+ "/tex/latex/graphics/graphics-2017-06-25.sty")
+ (string-append
+ #$output
+ "/share/texmf-dist/tex/latex/graphics")))))))))
+ (propagated-inputs (list texlive-graphics-def texlive-graphics-cfg))
+ (home-page "https://ctan.org/macros/latex/required/graphics")
+ (synopsis "The LaTeX standard graphics bundle")
+ (description
+ "This is a collection of LaTeX packages for: producing colour including
+graphics (e.g., PostScript) files rotation and scaling of text in LaTeX
documents. It comprises the packages color, graphics, graphicx, trig, epsfig,
keyval, and lscape.")
- (license license:lppl1.3c+)))
+ (license license:lppl1.3c))))
+
+(define-deprecated-package texlive-latex-graphics texlive-graphics)
(define-public texlive-latex-hycolor
(package
@@ -4316,6 +4343,7 @@ part of the LaTeX required set of packages.")
texlive-cm
texlive-cm-super ; to avoid bitmap fonts
texlive-fonts-latex
+ texlive-graphics
texlive-metafont
texlive-latex-base
texlive-kpathsea ;for mktex.opt
@@ -4325,7 +4353,6 @@ part of the LaTeX required set of packages.")
texlive-babel
texlive-generic-babel-english
texlive-latex-cyrillic
- texlive-latex-graphics
texlive-psnfss
texlive-latex-tools
texlive-tetex)))
@@ -4930,7 +4957,7 @@ rotated.")
(propagated-inputs
(list texlive-latex-bigfoot ; for suffix
texlive-filemod
- texlive-latex-graphics
+ texlive-graphics
texlive-latex-ifplatform
texlive-latex-l3kernel ; for expl3
texlive-oberdiek
@@ -6626,7 +6653,7 @@ Simple Young tableaux.
texlive-hyperref
texlive-latex-colortbl
texlive-latex-fancyhdr
- texlive-latex-graphics ;for color.sty
+ texlive-graphics ;for color.sty
texlive-latex-tools ;for array.sty
texlive-marvosym
texlive-tex-ini-files)) ;for pdftexconfig