summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-12-15 15:25:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-12-15 16:13:14 +0100
commit46b1e717cf0a3c931807377a836d8f6635b09aa3 (patch)
treed6407f8b09a9e18eaf092377930e6bf2a6018019 /gnu/packages
parentb2aa1d7cd06957c0267f68b93afaebf32af8be36 (diff)
gnu: python-ctxcore: Update to 0.2.0.
* gnu/packages/bioinformatics.scm (python-ctxcore): Update to 0.2.0. [build-system]: Use pyproject-build-system. [propagated-inputs]: Replace python-pyarrow-0.16 with python-pyarrow. Change-Id: I3f72f9872b438c0a624d23becb5d7828f1986da7
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8dc50c69fd..37cc08c8fe 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17990,7 +17990,7 @@ updated much more frequently.")
(define-public python-ctxcore
(package
(name "python-ctxcore")
- (version "0.1.1")
+ (version "0.2.0")
(source
(origin
(method git-fetch)
@@ -18000,8 +18000,8 @@ updated much more frequently.")
(file-name (git-file-name name version))
(sha256
(base32
- "16nlj7z8pirgjad7vlgm7226b3hpw4a7n967vyfg26dsf5n8k70d"))))
- (build-system python-build-system)
+ "0nv4lc46cnzpg5gcdxrsv7b4srmkq55zl3rcadw5pn3yyz5fzd2k"))))
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
@@ -18013,12 +18013,12 @@ updated much more frequently.")
(setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version))))))
(propagated-inputs
(list python-cytoolz
- python-numba
python-frozendict
+ python-numba
python-numpy
python-pandas
+ python-pyarrow
python-pyyaml
- python-pyarrow-0.16
python-tqdm))
(native-inputs
(list python-pytest