summaryrefslogtreecommitdiff
path: root/gnu/platforms/arm.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2022-05-23 22:37:26 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-05-25 09:27:25 +0200
commitdab819d5c4c55609efae098c8e3c2f2757c34e5b (patch)
tree43691e8653b203da8cd5100085f67253ce48f2a7 /gnu/platforms/arm.scm
parentd129d962e437fd215c5e9428fc1b26e2d72ffbda (diff)
Move (gnu platform) and (gnu platforms ...) to guix/.
* gnu/platform.scm: * gnu/platforms/arm.scm: * gnu/platforms/hurd.scm: * gnu/platforms/mips.scm: * gnu/platforms/powerpc.scm: * gnu/platforms/riscv.scm: * gnu/platforms/s390.scm: * gnu/platforms/x86.scm: Move to guix/. * Makefile.am: * doc/guix.texi (Porting to a New Platform): * etc/release-manifest.scm: * gnu/ci.scm: * gnu/image.scm: * gnu/local.mk: * gnu/packages/bioinformatics.scm: * gnu/packages/bootstrap.scm: * gnu/packages/cross-base.scm: * gnu/packages/instrumentation.scm: * gnu/packages/linux.scm: * gnu/system/image.scm: * gnu/system/images/hurd.scm: * gnu/system/images/novena.scm: * gnu/system/images/pine64.scm: * gnu/system/images/pinebook-pro.scm: * gnu/system/images/rock64.scm: * guix/scripts/build.scm: * guix/scripts/system.scm: * guix/self.scm: Update (gnu platform...) to (guix platform...). Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/platforms/arm.scm')
-rw-r--r--gnu/platforms/arm.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/platforms/arm.scm b/gnu/platforms/arm.scm
deleted file mode 100644
index bf68b2d00f..0000000000
--- a/gnu/platforms/arm.scm
+++ /dev/null
@@ -1,38 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu platforms arm)
- #:use-module (gnu platform)
- #:use-module (gnu packages linux)
- #:use-module (guix records)
- #:export (armv7-linux
- aarch64-linux))
-
-(define armv7-linux
- (platform
- (target "arm-linux-gnueabihf")
- (system "armhf-linux")
- (linux-architecture "arm")
- (glibc-dynamic-linker "/lib/ld-linux-armhf.so.3")))
-
-(define aarch64-linux
- (platform
- (target "aarch64-linux-gnu")
- (system "aarch64-linux")
- (linux-architecture "arm64")
- (glibc-dynamic-linker "/lib/ld-linux-aarch64.so.1")))