summaryrefslogtreecommitdiff
path: root/gnu/tests/install.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-30 23:47:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-30 23:47:49 +0200
commit8bf8cd9b85c85be387565f6c8ca9f6c72196fb8e (patch)
tree6fa0f8ba32b83a996625bc188903ccebfb7e7c2c /gnu/tests/install.scm
parent5d9e2187929ed7e8d46ec3cb3174fd78c1846360 (diff)
parent229f4fa9522fb56b014ee9c0d8111e8fb6da764d (diff)
Merge branch 'master' into core-updates
Conflicts: gnu/local.mk gnu/packages/backup.scm gnu/packages/emacs-xyz.scm gnu/packages/guile.scm gnu/packages/lisp.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/web.scm gnu/packages/xorg.scm
Diffstat (limited to 'gnu/tests/install.scm')
-rw-r--r--gnu/tests/install.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/tests/install.scm b/gnu/tests/install.scm
index 1b113602ed..343fdc67f6 100644
--- a/gnu/tests/install.scm
+++ b/gnu/tests/install.scm
@@ -254,7 +254,7 @@ packages defined in installation-os."
(make-marionette
`(,(which #$(qemu-command system))
"-no-reboot"
- "-m" "800"
+ "-m" "1200"
#$@(cond
((string=? "ext4" installation-disk-image-file-system-type)
#~("-drive"
@@ -389,6 +389,7 @@ per %test-installed-os, this test is expensive in terms of CPU and storage.")
(services (cons (service marionette-service-type
(marionette-configuration
(imported-modules '((gnu services herd)
+ (guix build utils)
(guix combinators)))))
%base-services))))
@@ -1060,7 +1061,7 @@ build (current-guix) and then store a couple of full system images.")
(define* (installation-target-os-for-gui-tests
#:key (encrypted? #f))
(operating-system
- (inherit %minimal-os)
+ (inherit %minimal-os-on-vda)
(users (append (list (user-account
(name "alice")
(comment "Bob's sister")
@@ -1076,9 +1077,9 @@ build (current-guix) and then store a couple of full system images.")
%base-user-accounts))
;; The installer does not create a swap device in guided mode with
;; encryption support.
- (swap-devices (if encrypted? '() '("/dev/vdb2")))
+ (swap-devices (if encrypted? '() '("/dev/vda2")))
(services (cons (service dhcp-client-service-type)
- (operating-system-user-services %minimal-os)))))
+ (operating-system-user-services %minimal-os-on-vda)))))
(define* (installation-target-desktop-os-for-gui-tests
#:key (encrypted? #f))