summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:02 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:17 -0500
commit032cac46ed01ceb628a08bdbcc97b256a71002ab (patch)
tree42b6abe863410149f0ef0369c80f2e484126b2b0 /gnu
parentb184a16c141d110840b023851b233dfe032a2f72 (diff)
gnu: go-github-com-gorilla-context: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-context): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I22ba5493a48fe619ef2aca185c559da3a81f8d81
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm26
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 9e68e96baf..012ed0429c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -146,6 +146,32 @@ metrics (i.e. response time, bytes written, and http status code) from your
application's http.Handlers.")
(license license:expat)))
+(define-public go-github-com-gorilla-context
+ (let ((commit "08b5f424b9271eedf6f9f0ce86cb9396ed337a42")
+ (revision "0"))
+ (package
+ (name "go-github-com-gorilla-context")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/context")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03p4hn87vcmfih0p9w663qbx9lpsf7i7j3lc7yl7n84la3yz63m4"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gorilla/context"))
+ (home-page "https://github.com/gorilla/context")
+ (synopsis "Go registry for request variables")
+ (description
+ "This package provides @code{gorilla/context}, which is a general
+purpose registry for global request variables in the Go programming
+language.")
+ (license license:bsd-3))))
+
(define-public go-github-com-gorilla-csrf
(package
(name "go-github-com-gorilla-csrf")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index acffd91dde..52d65d4967 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4641,30 +4641,6 @@ information about the resource usage and performance characteristics of running
containers.")
(license license:asl2.0))))
-(define-public go-github-com-gorilla-context
- (let ((commit "08b5f424b9271eedf6f9f0ce86cb9396ed337a42")
- (revision "0"))
- (package
- (name "go-github-com-gorilla-context")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gorilla/context")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "03p4hn87vcmfih0p9w663qbx9lpsf7i7j3lc7yl7n84la3yz63m4"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/gorilla/context"))
- (home-page "https://github.com/gorilla/context")
- (synopsis "Go registry for request variables")
- (description "This package provides @code{gorilla/context}, which is a general purpose registry for global request variables in the Go programming language.")
- (license license:bsd-3))))
-
(define-public go-github-com-andybalholm-brotli
(package
(name "go-github-com-andybalholm-brotli")