summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-31 15:45:10 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-31 21:59:10 -0500
commit055d595bf85495501d47f71df4b253fe677904f8 (patch)
tree2279667a4b7d042c7169bb96015ac40c1115c2e9 /gnu
parentbf7991a8c767abd32cfb2c92e3d57665a7cabf00 (diff)
gnu: dhtnet: Update to 0.0.1-1.41848a2.
* gnu/packages/networking.scm (dhtnet): Update to 0.0.1-1.41848a2. [inputs]: Add yaml-cpp. Change-Id: I399260201e09185c33bbd441eb1a877a43e10d9f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index d6ad69bba8..6416c97625 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3986,8 +3986,8 @@ A very simple IM client working over the DHT.
(define-public dhtnet
;; There is no tag nor release; use the latest available commit.
- (let ((revision "0")
- (commit "8b6e99fd34f150fde5f21f3a57e0e9f28174c70c"))
+ (let ((revision "1")
+ (commit "41848a2c770d7eb0940d731014b81643f85e0d07"))
(package
(name "dhtnet")
;; The base version is taken from the CMakeLists.txt file.
@@ -4000,7 +4000,7 @@ A very simple IM client working over the DHT.
(file-name (git-file-name name version))
(sha256
(base32
- "1yhygsimcl9j6hbww1b77am1kgbcriczslcrfb838nbfh18n1780"))))
+ "18v2pjrxfrd26p2z27s90marx7b593nz1xwi47lnp2ja7lm1pj4m"))))
(outputs (list "out" "debug"))
(build-system cmake-build-system)
(arguments
@@ -4031,7 +4031,8 @@ A very simple IM client working over the DHT.
opendht
libupnp
pjproject-jami
- readline))
+ readline
+ yaml-cpp))
(home-page "https://github.com/savoirfairelinux/dhtnet/")
(synopsis "OpenDHT network library for C++")
(description "The @code{dhtnet} is a C++ library providing abstractions