summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:31:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:36 +0200
commit0a8e86831b57c10fb553ca7854c715e72368bf33 (patch)
tree86e5d7f23112ca4cbdc5af9420f17978852d5542 /gnu
parent585a7d56f1db3a4f8f6a5a4bc495cfc806285260 (diff)
gnu: Add texlive-gchords.
* gnu/packages/tex.scm (texlive-gchords): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index adc3115b79..070cb03525 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6481,6 +6481,27 @@ nets, diagrams, etc., very easily, in the LaTeX @code{picture} environment.")
glosses, and various other goodies.")
(license license:lppl1.2+)))
+(define-public texlive-gchords
+ (package
+ (name "texlive-gchords")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/gchords/" "tex/latex/gchords/")
+ (base32
+ "0wchfk25v6rh5nffjyn8bypwjsqc9pi2rjrw3np65a0sxxc0sl1v")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/gchords")
+ (synopsis "Typeset guitar chords")
+ (description
+ "This package provides a LaTeX package for typesetting of guitar chord
+diagrams, including options for chord names, finger numbers and typesetting
+above lyrics. The bundle also includes a TCL script (@file{chordbox.tcl})
+that provides a graphical application which creates LaTeX files that use
+@file{gchords.sty}.")
+ (license license:gpl3+)))
+
(define-public texlive-gene-logic
(package
(name "texlive-gene-logic")