summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-11 23:29:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-11 23:30:49 +0200
commit0f272518eca06f849cef86d26c294f17edc82c3e (patch)
treee499f00a443ae62b4c19e6d451f1c874e94727f1 /gnu
parent6f2f7bc88aa093f87874fcfaa27366074978d9ee (diff)
gnu: python-ipython-documentation: Make reproducible.
Fixes <https://bugs.gnu.org/37373/>. * gnu/packages/python-xyz.scm (python-ipython)[arguments]: Add phase "make-docs-reproducible" to remove timestamps from documentation generated in dependent python-ipython-documentation package.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 819b3045a3..00bffca74a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5399,6 +5399,13 @@ computing.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-docs-reproducible
+ (lambda _
+ (substitute* "IPython/sphinxext/ipython_directive.py"
+ ((".*import datetime") "")
+ ((".*datetime.datetime.now\\(\\)") "")
+ (("%timeit") "# %timeit"))
+ #t))
;; Tests can only be run after the library has been installed and not
;; within the source directory.
(delete 'check)