summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-02-03 07:43:07 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 13:14:15 -0500
commit11d1bc35695ecbbb69b3019c481fd7c6134b8121 (patch)
tree90bd69e1fb384aed3dab6222cf791515d9811412 /gnu
parentbc8ec36b14e94a91a8e5f4ad2f8691cbee0454d2 (diff)
gnu: font-comic-neue: Install license file.
* gnu/packages/fonts.scm (font-comic-neue)[arguments]<#:phases>: Add "enter-license-directory" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fonts.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 62cd9de607..172b32428e 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1702,8 +1702,7 @@ later hand-tweaked with the gbdfed(1) editor:
;; several hidden files to be installed.
(add-before 'install 'delete-macosx-files
(lambda _
- (delete-file-recursively "__MACOSX")
- #t))
+ (delete-file-recursively "__MACOSX")))
(add-after 'install 'install-conf
(lambda* (#:key outputs #:allow-other-keys)
(let ((conf-dir (string-append (assoc-ref outputs "out")
@@ -1722,8 +1721,10 @@ later hand-tweaked with the gbdfed(1) editor:
<family>Comic Neue</family>
</prefer>
</alias>
-</fontconfig>\n"))))
- #t)))))
+</fontconfig>\n"))))))
+ (add-before 'install-license-files 'enter-license-directory
+ (lambda _
+ (chdir (string-append "comic-neue-" ,version)))))))
(home-page "https://www.comicneue.com/")
(synopsis "Font that fixes the shortcomings of Comic Sans")
(description