summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-30 15:56:45 +0800
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:11 +0200
commit13cb9b302868b5a966a6ae177412c474084f4bf1 (patch)
tree12b6131f3cd85c9aad3e6356af3398fa20d25d7c /gnu
parentf858d5c8a5270e5db189dc7cc2fa8ffe83c16ef5 (diff)
gnu: python-wand: Fix build.
Fixes <https://issues.guix.gnu.org/64350>. * gnu/packages/python-xyz.scm (python-wand)[arguments]<#:phases>: Pass tests? to 'check. Reported-by: Thorsten Wilms <t_w_@freenet.de> Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6a29701219..755b0af4b6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2446,7 +2446,7 @@ conventions and aliases in the same expression.")
(setenv "MAGICK_HOME" (assoc-ref inputs "imagemagick"))
(setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16")))
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest" "-vv")))))))
(native-inputs