summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-15 16:32:04 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-15 16:32:04 +0200
commit1682aba2473642f9b282916e4b8f3a1cdb3f35fc (patch)
treec04c53bae28dcc05fdb5039dc28fb1bfb65d47ce /gnu
parent4cb5144df0d352b49bddcd4e6d284481fb3d9f36 (diff)
gnu: emacs-next: Update to 29.0.50-2.4aeb80c.
* gnu/packages/patches/emacs-native-comp-driver-options.patch: New file. * gnu/local.mk: Register it here. * gnu/packages/emacs.scm (emacs-next): Update to 29.0.50-2.4aeb80c.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs.scm10
-rw-r--r--gnu/packages/patches/emacs-native-comp-driver-options.patch17
3 files changed, 25 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0c77571392..1bd4722db4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1062,6 +1062,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
+ %D%/packages/patches/emacs-native-comp-driver-options.patch \
%D%/packages/patches/emacs-polymode-fix-lexical-variable-error.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
%D%/packages/patches/emacs-telega-path-placeholder.patch \
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a560481dd9..8094e017dd 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -381,8 +381,8 @@ languages.")
(license license:gpl3+)))
(define-public emacs-next
- (let ((commit "0a5477b448e6b62bcedc1803e531ec7686eea48d")
- (revision "1"))
+ (let ((commit "4aeb80ccecd0dc3f3b3f567779632a0f23476a09")
+ (revision "2"))
(package
(inherit emacs)
(name "emacs-next")
@@ -395,9 +395,13 @@ languages.")
(url "https://git.savannah.gnu.org/git/emacs.git/")
(commit commit)))
(file-name (git-file-name name version))
+ ;; emacs-source-date-epoch.patch is no longer necessary
+ (patches (search-patches "emacs-exec-path.patch"
+ "emacs-fix-scheme-indent-function.patch"
+ "emacs-native-comp-driver-options.patch"))
(sha256
(base32
- "0dqmrawkvbypxp8gcnspnhhmfamzp3l62gfgp1pw2l6svz58v991"))))
+ "0rr2iiqsma37gbg4irn69cc2f3mr83ndycg0dsl3ba96i5fw60zs"))))
(inputs
(modify-inputs (package-inputs emacs)
(prepend sqlite)))
diff --git a/gnu/packages/patches/emacs-native-comp-driver-options.patch b/gnu/packages/patches/emacs-native-comp-driver-options.patch
new file mode 100644
index 0000000000..308c4f1212
--- /dev/null
+++ b/gnu/packages/patches/emacs-native-comp-driver-options.patch
@@ -0,0 +1,17 @@
+We substitute this anyway, so let's make it easier to substitute.
+
+--- a/lisp/emacs-lisp/comp.el
++++ b/lisp/emacs-lisp/comp.el
+@@ -178,8 +178,7 @@ and above."
+ :type '(repeat string)
+ :version "28.1")
+
+-(defcustom native-comp-driver-options (when (eq system-type 'darwin)
+- '("-Wl,-w"))
++(defcustom native-comp-driver-options nil
+ "Options passed verbatim to the native compiler's back-end driver.
+ Note that not all options are meaningful; typically only the options
+ affecting the assembler and linker are likely to be useful.
+--
+2.38.0
+