summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-21 16:44:43 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-21 16:44:43 -0500
commit1a97e68de9527716f536fb0dc1ad028d0742a60d (patch)
tree517240866a6251292a9bb9ae69630990b1a87ab3 /gnu
parent895389583b5a559c13c84653d8cc4a7ec716893d (diff)
gnu: cheese: Use gexps.
* gnu/packages/gnome.scm (cheese) [arguments]: Use gexps. [phases] {wrap-cheese}: Delete extraneous INPUTS binding.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 375fb59f3c..1e68e7568d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11451,19 +11451,19 @@ photo-booth-like software, such as Cheese.")
(base32
"02vzcvk2s6cwvdw6v6qmlq3znamy6zwv7l6nlbqjfwrj7i54qmvl"))))
(arguments
- `(#:glib-or-gtk? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- (lambda _
- ;; Don't create 'icon-theme.cache'
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))))
- (add-after 'install 'wrap-cheese
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (wrap-program (search-input-file outputs "bin/cheese")
- `("GST_PLUGIN_SYSTEM_PATH" ":" prefix
- (,(getenv "GST_PLUGIN_SYSTEM_PATH")))))))))
+ (list #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ ;; Don't create 'icon-theme.cache'.
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") (which "true")))))
+ (add-after 'install 'wrap-cheese
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/cheese")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix
+ (,(getenv "GST_PLUGIN_SYSTEM_PATH")))))))))
(build-system meson-build-system)
(native-inputs
(list docbook-xsl