summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-09 21:23:30 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 16:29:43 -0400
commit1e16c302770a959d4a63044f21d22c089207430d (patch)
treeace37360493a40dc86ea361f7dc6aa9dc09d4aad /gnu
parent1b34efe8f595736078c5f56118fd448c84219b2e (diff)
gnu: global: Fix ctags creation using pygments.
* gnu/packages/code.scm (global)[arguments]: Adjust configure-flags to use a specific python interpreter.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/code.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 9cdda2b751..1c21ad475b 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -200,6 +200,10 @@ highlighting your own code that seemed comprehensible when you wrote it.")
(string-append "--with-universal-ctags="
#$(this-package-input "universal-ctags")
"/bin/ctags")
+ ;; Otherwise this gets overridden in the 'configure phase.
+ (string-append "--with-python-interpreter="
+ #$(this-package-input "python-wrapper")
+ "/bin/python")
(string-append "--sysconfdir="
#$output "/share/gtags")
"--localstatedir=/var" ; This needs to be a writable location.