summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-21 03:52:48 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 22:36:34 +0200
commit2181133eed4d392db5ad533f5e22b0dbb1951f35 (patch)
tree49b59d05bb9f179c149f05b0da4010464d3fa42a /gnu
parent3a4107b28686ef256e0158f545f26b1d852ecb7b (diff)
gnu: Add python-emoji.
* gnu/packages/python-xyz.scm (python-emoji): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ea157ad28..2836cf799c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9716,6 +9716,33 @@ It implements the complete mapping interface and can be used as a drop-in
replacement for dictionaries where immutability is desired.")
(license license:expat)))
+(define-public python-emoji
+ (package
+ (name "python-emoji")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "emoji" version))
+ (sha256
+ (base32 "0923mpixwq6hdpkgvi4r46alfvf608iq975rb8lnqpq29j71mmjk"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/carpedm20/emoji/")
+ (synopsis "Emoji terminal output for Python")
+ (description "This package provides Emoji terminal output for Python. The
+entire set of Emoji codes as defined by the Unicode Consortium is supported in
+addition to a bunch of aliases.")
+ (license license:bsd-3)))
+
(define-public python-pep8
;; This package has been renamed to ‘pycodestyle’ and is no longer updated.
;; Its last release (1.7.1) adds only a scary warning to this effect, breaking