summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-03 12:14:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:38:24 +0300
commit28e37f1e05ec5bc6fac3cb1a927c7bb1b63829da (patch)
treec16721d14057e30258cd0f91b05daee7d400be49 /gnu
parent07d098db7481895eb3494d15c6511d8225331597 (diff)
gnu: rust-indexmap-1: Update to 1.9.3.
* gnu/packages/crates-io.scm (rust-indexmap-1): Update to 1.9.3. [cargo-inputs]: Add rust-autocfg-1, rust-hashbrown-0.12, rust-rayon-1. Replace rust-rustc-rayon-0.4 with 0.5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index abe21045be..7fb3c69d91 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31584,19 +31584,22 @@ or numerical index. A corresponding hash set type is also provided.")
(package
(inherit rust-indexmap-2)
(name "rust-indexmap")
- (version "1.9.2")
+ (version "1.9.3")
(source
(origin
(method url-fetch)
(uri (crate-uri "indexmap" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "16dkr2h5p379jcr8rnb420396yvzid2myirc2w70zcf43yffg18q"))))
+ (base32 "16dxmy7yvk51wvnih3a3im6fp5lmx0wx76i03n06wyak6cwhw1xx"))))
(arguments
`(#:cargo-inputs
(("rust-arbitrary" ,rust-arbitrary-1)
+ ("rust-autocfg" ,rust-autocfg-1)
+ ("rust-hashbrown" ,rust-hashbrown-0.12)
("rust-quickcheck" ,rust-quickcheck-1)
- ("rust-rustc-rayon" ,rust-rustc-rayon-0.4)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-rustc-rayon" ,rust-rustc-rayon-0.5)
("rust-serde" ,rust-serde-1))
#:cargo-development-inputs
(("rust-fnv" ,rust-fnv-1)