summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:41:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:55 +0200
commit2bc85d9380b479b8d5b3dbea7c4ce8d527c0c075 (patch)
tree39f0c9b96a8898ea810630adfb52cdce62fb6880 /gnu
parentd88e2fdd3811142b72478e9728399ea613edc156 (diff)
gnu: Add texlive-dtl.
* gnu/packages/tex.scm (texlive-dtl): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0bfb25c175..c52903dcbb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1638,6 +1638,29 @@ code navigation, and related functionality to any text editor that speaks the
LSP protocol.")
(license (list license:gpl3+ license:lppl1.3+ license:fdl1.3+))))
+(define-public texlive-dtl
+ (package
+ (name "texlive-dtl")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/dt2dv.1"
+ "doc/man/man1/dt2dv.man1.pdf"
+ "doc/man/man1/dv2dt.1"
+ "doc/man/man1/dv2dt.man1.pdf")
+ (base32
+ "0kvnsr8nxrys99rp74wlxnisfripx6jpjjkqy38d3d4gw13cvb5g")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/dtl")
+ (synopsis "Tools to dis-assemble and re-assemble DVI files")
+ (description
+ "DTL (DVI Text Language) is a means of expressing the content of a DVI file,
+which is readily readable by humans. The DTL bundle contains an assembler
+@command{dt2dv}, which produces DVI files from DTL files, and a disassembler
+@command{dv2dt}, which produces DTL files from DVI files.")
+ (license license:public-domain)))
+
(define-public texlive-dvipsconfig
(package
(name "texlive-dvipsconfig")