summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-10-04 21:58:28 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-10-04 22:02:52 +1000
commit2c3eb4b85be765dadcb19d65507063de4cc9dde7 (patch)
tree56e9b17b6554b235ab7d0478879398df422cbd00 /gnu
parent47c14714a400c912243a79c421e0f0cfd4a0d55d (diff)
gnu: metabat: Update to 0.32.4-1.cbdca756.
* gnu/packages/bioinformatics.scm (metabat): Update to 0.32.4-1.cbdca756. * gnu/packages/patches/metabat-remove-compilation-date.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm31
-rw-r--r--gnu/packages/patches/metabat-remove-compilation-date.patch16
3 files changed, 35 insertions, 13 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2637791b81..42b95a881e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -691,6 +691,7 @@ dist_patch_DATA = \
%D%/packages/patches/mcrypt-CVE-2012-4409.patch \
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
+ %D%/packages/patches/metabat-remove-compilation-date.patch \
%D%/packages/patches/mhash-keygen-test-segfault.patch \
%D%/packages/patches/mpc123-initialize-ao.patch \
%D%/packages/patches/mplayer2-theora-fix.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cf20057bcd..ac46fe4bcc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3221,18 +3221,23 @@ form of assemblies or reads.")
license:cpl1.0)))) ; Open Bloom Filter
(define-public metabat
- (package
- (name "metabat")
- (version "0.26.3")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://bitbucket.org/berkeleylab/metabat/get/"
- version ".tar.bz2"))
- (file-name (string-append name "-" version ".tar.bz2"))
- (sha256
- (base32
- "1vpfvgsn8wdsv1g7z73zxcncskx7dy7bw5msg1hhibk25ay11pyg"))))
+ ;; We package from a git commit because compilation of the released version
+ ;; fails.
+ (let ((commit "cbdca756993e66ae57e50a27970595dda9cbde1b"))
+ (package
+ (name "metabat")
+ (version (string-append "0.32.4-1." (string-take commit 8)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://bitbucket.org/berkeleylab/metabat.git")
+ (commit commit)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0byia8nsip6zvc4ha0qkxkxxyjf4x7jcvy48q2dvb0pzr989syzr"))
+ (patches (search-patches "metabat-remove-compilation-date.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -3299,7 +3304,7 @@ enables the study of individual organisms and their interactions. MetaBAT is
an automated metagenome binning software, which integrates empirical
probabilistic distances of genome abundance and tetranucleotide frequency.")
(license (license:non-copyleft "file://license.txt"
- "See license.txt in the distribution."))))
+ "See license.txt in the distribution.")))))
(define-public minced
(package
diff --git a/gnu/packages/patches/metabat-remove-compilation-date.patch b/gnu/packages/patches/metabat-remove-compilation-date.patch
new file mode 100644
index 0000000000..7672205b22
--- /dev/null
+++ b/gnu/packages/patches/metabat-remove-compilation-date.patch
@@ -0,0 +1,16 @@
+Remove the reference to the compilation date so that the build is
+reproducible.
+
+diff --git a/src/metabat.cpp b/src/metabat.cpp
+index 88e06de..c95cb1a 100644
+--- a/src/metabat.cpp
++++ b/src/metabat.cpp
+@@ -49,7 +49,7 @@ int main(int ac, char* av[]) {
+ po::notify(vm);
+
+ if (vm.count("help") || inFile.length() == 0 || outFile.length() == 0) {
+- cerr << "\nMetaBAT: Metagenome Binning based on Abundance and Tetranucleotide frequency (version " << version << "; " << __DATE__ << " " << __TIME__ << ")" << endl;
++ cerr << "\nMetaBAT: Metagenome Binning based on Abundance and Tetranucleotide frequency (version " << version << "; unknown compilation date)" << endl;
+ cerr << "by Don Kang (ddkang@lbl.gov), Jeff Froula, Rob Egan, and Zhong Wang (zhongwang@lbl.gov) \n" << endl;
+ cerr << desc << endl << endl;
+