summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-06-17 10:06:12 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-06-17 11:25:23 +0200
commit2fa9a183d711df67dfbb5bfafed56edd2ef39ac0 (patch)
tree5978b5089261dcbef0e78b2502665ebf022faf3b /gnu
parentdec270a7c86daf1ab77ea438b9613fd99ec404a0 (diff)
gnu: stumpwm: Don't install build artifacts.
* gnu/packages/wm.scm (stumpwm)[arguments]: Add 'remove-temporary-cache' phase. (stumpwm+slynk)[arguments]: Delete 'remove-temporary-cache' phase inherited from stumpwm.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index e707a15785..c380abc0e8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2044,7 +2044,11 @@ Wayland compositors supporting the wlr-output-management protocol.")
(invoke "./autogen.sh")
(invoke "sh" "./configure" "SHELL=sh")
(apply invoke "make" "stumpwm.info" make-flags)
- (install-file "stumpwm.info" info)))))))
+ (install-file "stumpwm.info" info))))
+ (add-after 'install-manual 'remove-temporary-cache
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively (string-append (assoc-ref outputs "lib")
+ "/.cache")))))))
(synopsis "Window manager written in Common Lisp")
(description
"Stumpwm is a window manager written entirely in Common Lisp.
@@ -2087,6 +2091,7 @@ productive, customizable lisp based systems.")
(delete 'copy-source)
(delete 'build)
(delete 'check)
+ (delete 'remove-temporary-cache)
(delete 'cleanup)))))))
(define stumpwm-contrib