summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:42 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:22 +0300
commit2ff1c352d4032a588f4b0d8ebe0eb3e946fbc3e1 (patch)
tree8c44bbfcb43cddd0767c800f9f11f7a83d0b2cd8 /gnu
parent23bc5e12d44122991062ad68a489ab10949142aa (diff)
gnu: Add python-stdatamodels.
* gnu/packages/astronomy.scm (python-stdatamodels): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 8f3471daab..ac4b6eea96 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2174,6 +2174,48 @@ task}.")
image processing functions: @code{xyxymatch}, @code{geomap}.")
(license license:bsd-3)))
+(define-public python-stdatamodels
+ (package
+ (name "python-stdatamodels")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "stdatamodels" version))
+ (sha256
+ (base32
+ "1lssz5mnkzgraqa9mdg1w39scsikymcp3zpmsjb146r0pqnwnpzw"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Disable tests requiring access to CRDS servers to download ~500MiB
+ ;; of data.
+ #:test-flags #~(list "-k" "not test_crds_selectors_vs_datamodel")
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list python-asdf
+ python-asdf-astropy
+ python-astropy
+ python-jsonschema
+ python-numpy
+ python-psutil))
+ (native-inputs (list python-crds
+ python-pytest
+ python-pytest-doctestplus
+ python-pytest-openfiles
+ python-scipy
+ python-semantic-version
+ python-setuptools-scm))
+ (home-page "https://github.com/spacetelescope/stdatamodels")
+ (synopsis
+ "Core support for DataModel classes used in calibration pipelines")
+ (description
+ "Provides DataModel, which is the base class for data models implemented in
+the @acronym{JWST, James Webb Space Telescope} and @acronym{Roman, Nancy Grace
+Roman Space Telescope} calibration software.")
+ (license license:bsd-3)))
+
(define-public python-stsynphot
(package
(name "python-stsynphot")