summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOntje Lünsdorf <ontje.luensdorf@dlr.de>2023-03-22 09:42:09 +0100
committerLudovic Courtès <ludo@gnu.org>2023-06-16 00:14:52 +0200
commit31336e9f5d68512a9c1c6826bce9f17c892a2125 (patch)
tree46ead53a956ba20365c528d2de24a332e5e65aa0 /gnu
parent248cf06149b4f09bfca4a21710bc8e1bd47f6e61 (diff)
gnu: Add python-pdoc.
* gnu/packages/python-xyz.scm (python-pdoc): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 141fa1d05b..cdffc3ad67 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -138,6 +138,7 @@
;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
+;;; Copyright © 2023 Ontje Lünsdorf <ontje.luensdorf@dlr.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1065,6 +1066,38 @@ MySQL databases, using an API that is compliant with the Python Database API
Specification v2.0 (PEP 249).")
(license license:gpl2)))
+(define-public python-pdoc
+ (package
+ (name "python-pdoc")
+ (version "13.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mitmproxy/pdoc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gxkw607nrd67ck4w8jri9vfrm5g60qvp8b134m8zkiphbxjnx0l"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-jinja2 python-pygments))
+ (arguments
+ (list
+ ;; Some tests fail, presumably because of slight version mismatches of
+ ;; the dependencies.
+ #:test-flags
+ '(list "-k" (string-append "not test_var_with_raising_repr and "
+ "not test_smoke[mock] and "
+ "not test_snapshots[html"))))
+ (home-page "https://pdoc.dev/")
+ (synopsis "API documentation for Python projects")
+ (description "pdoc auto-generates API documentation that follows your
+project's Python module hierarchy. It requires no configuration, has
+first-class support for type annotations, cross-links between identifiers,
+comes with an integrated live-reloading web server, uses customizable HTML
+templates, understands numpydoc and Google-style docstrings.")
+ (license license:unlicense)))
+
(define-public python-py4j
(package
(name "python-py4j")