summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 16:38:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 19:08:29 +0200
commit33bcd6c0cbfcd24b6de26c7a41d2134ed2c370dd (patch)
tree748d81f10647e3cd40ecf57c77a7393e47a443dd /gnu
parent68573b22b47c85d7fea9bd1296d483f58f40feca (diff)
gnu: Add texlive-greektonoi.
* gnu/packages/tex.scm (texlive-greektonoi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f0e6d1c649..43a03f8ea5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11576,6 +11576,35 @@ ancient way, such as @code{\\today}.")
Greek hyphenation patterns for the fonts encoding are also provided.")
(license license:public-domain)))
+(define-public texlive-greektonoi
+ (package
+ (name "texlive-greektonoi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/greektonoi/"
+ "fonts/map/dvips/greektonoi/"
+ "tex/latex/greektonoi/")
+ (base32
+ "14phabwakq87qgh3jxs95gk1w2q3aw29vhy441538y4fxvskqhrw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/greektonoi")
+ (synopsis "Facilitates writing/editing of multiaccented Greek")
+ (description
+ "The @code{greektonoi} mapping extends the @code{betababel} package or
+the Babel @samp{polutonikogreek} option to provide a simple way to insert
+ancient Greek texts with diacritical characters into your document using
+a similar method to the commonly used Beta Code transliteration, but with much
+more freedom. It is designed especially for the XeTeX engine and it could
+also be used for fast and easy modification of monotonic Greek texts to
+polytonic. The output text is natively encoded in Unicode, so it can be
+reused in any possible way. The @code{greektonoi} package provides, in
+addition to inserting Greek accents and breathings, many other symbols used in
+Greek numbers and arithmetic or in the Greek archaic period. It could be used
+with @code{greektonoi} mapping or indepedently.")
+ (license license:lgpl3)))
+
(define-public texlive-gtl
(package
(name "texlive-gtl")