summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorThanos Apollo <public@thanosapollo.com>2023-08-14 12:38:19 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 16:29:45 -0400
commit38988f9c3f922572bdfd4ccf4a4c2af8aa3add7d (patch)
tree1ca5b07db00b77b4d316ddb6a8cea45262dcd321 /gnu
parentd563de81fe542de05de6eb4c2ea004861888f3d6 (diff)
gnu: Add emacs-yeetube.
* gnu/packages/emacs-xyz.scm (emacs-yeetube): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e971edb676..355afbf8fb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -134,6 +134,7 @@
;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
+;;; Copyright © 2023 Thanos Apollo <public@thanosapollo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27896,6 +27897,33 @@ as playing them in some video player, or downloading them.")
and comments.")
(license license:gpl3+))))
+(define-public emacs-yeetube
+ (package
+ (name "emacs-yeetube")
+ (version "1.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~thanosapollo/yeetube.el")
+ (commit version)))
+ (sha256
+ (base32
+ "0vfap6sri6qnswrjsp6qvmrp98bvrfh58gwdqbjiakq1fzvcrm03"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (inputs
+ (list mpv yt-dlp))
+ (home-page "https://sr.ht/~thanosapollo/yeetube.el")
+ (synopsis "Youtube & Invidious front-end for Emacs")
+ (description
+ "This package offers an Emacs interface that allows you to search YouTube
+or an Invidious instance for a specific query. The search results are shown as
+links in an org-mode buffer. The videos can be opened to a user-defined video
+player(by default mpv) or downloaded using yt-dlp. This package also includes
+a yt-dlp front-end.")
+ (license license:gpl3+)))
+
(define-public emacs-org-web-tools
(package
(name "emacs-org-web-tools")