summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-01-13 16:07:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-14 08:13:54 +0100
commit3e1c85b7ec9e694168dd322dcc93866b666beba9 (patch)
tree28f113e4bcf53358e4fae82aa4dc58c076012250 /gnu
parentc77978d6c8d28e34e656f5b22ae9f0927e2f2dec (diff)
gnu: Add r-maser.
* gnu/packages/bioconductor.scm (r-maser): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c2fa26cb59..ca236bcf75 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6274,6 +6274,38 @@ containing the location/probe set membership mapping. The other one creates a
package that automatically loads that environment.")
(license license:gpl2+)))
+(define-public r-maser
+ (package
+ (name "r-maser")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "maser" version))
+ (sha256
+ (base32
+ "1zycx8s046g4d3w5qrn950bmi0nrnq1g7fvqji48mr6hmsyzplvv"))))
+ (properties `((upstream-name . "maser")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocgenerics
+ r-data-table
+ r-dplyr
+ r-dt
+ r-genomeinfodb
+ r-genomicranges
+ r-ggplot2
+ r-gviz
+ r-iranges
+ r-reshape2
+ r-rtracklayer))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/DiogoVeiga/maser")
+ (synopsis "Mapping alternative splicing events to proteins")
+ (description
+ "This package provides functionalities for downstream analysis, annotation
+and visualizaton of alternative splicing events generated by rMATS.")
+ (license license:expat)))
+
(define-public r-metaneighbor
(package
(name "r-metaneighbor")