summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDominic Martinez <dom@dominicm.dev>2024-02-11 19:28:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-12 23:33:22 +0000
commit3fa6971f2c6e3d796b18fd01cba2d062d63ffe93 (patch)
treef0ae383f2a9bceae5e3bdfe675a452e8468c622a /gnu
parent0969cb0b48b676155b6a4f5528247b9653e90889 (diff)
gnu: Add go-github-com-armon-go-radix.
* gnu/packages/golang-xyz.scm (go-github-com-armon-go-radix): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Iee5b73c53cca088a05563377b691d607cc745b0e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9aab17d10e..3b69c8fb36 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -60,6 +60,28 @@
shell-like commands.")
(license license:expat)))
+(define-public go-github-com-armon-go-radix
+ (package
+ (name "go-github-com-armon-go-radix")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/armon/go-radix")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1m1k0jz9gjfrk4m7hjm7p03qmviamfgxwm2ghakqxw3hdds8v503"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/armon/go-radix"))
+ (home-page "https://github.com/armon/go-radix")
+ (synopsis "Go implementation of Radix trees")
+ (description "This package provides a single @code{Tree} implementation,
+optimized for sparse nodes of
+@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
+ (license license:expat)))
+
(define-public go-github-com-djherbis-atime
(package
(name "go-github-com-djherbis-atime")