summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-10-05 21:34:49 +0000
committerLudovic Courtès <ludo@gnu.org>2023-10-06 12:26:45 +0200
commit3fc3b35738c4c854bb34c9e929a254bbe8d28b25 (patch)
tree131a42b59cf62c4a9405dc6df9d269e4bdda0983 /gnu
parent97edef50f420b719a3c8d250096c64d5e04646b9 (diff)
gnu: Add suitesparse-colamd.
* gnu/packages/maths.scm (suitesparse-colamd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e2c0492ccb..fade383ca7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5246,6 +5246,39 @@ It is a variant of AMD which has the the option to apply constraints to the
ordering.")
(license license:bsd-3)))
+(define-public suitesparse-colamd
+ (package
+ (name "suitesparse-colamd")
+ (version "3.2.0")
+ (source suitesparse-source)
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "COLAMD")))
+ (add-after 'chdir 'set-cmake-module-path
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set.*CMAKE_MODULE_PATH.*")
+ (string-append "set(CMAKE_MODULE_PATH "
+ #$suitesparse-config "/lib/cmake/SuiteSparse)\n"
+ "set(DUMMY\n")))))
+ (replace 'install-license-files
+ (lambda _
+ (install-file "../COLAMD/Doc/License.txt"
+ (string-append #$output "/share/doc/"
+ #$name "-" #$version)))))))
+ (inputs (list suitesparse-config))
+ (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+ (synopsis "Column Approximate Minimum Degree Ordering")
+ (description "COLAMD is library for computing a permutation vector for a
+matrix with which the LU factorization becomes sparser.")
+ (license license:bsd-3)))
+
(define-public suitesparse
(package
(name "suitesparse")