summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:44:55 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:44:55 +0000
commit3fec61b1c978845adda96e37ebfcc46cae30e604 (patch)
treec25cec9d2ba4b59a0f8811c3204d9c52d591538d /gnu
parentcb1107416e51fc90d5031f3d9c71510e6eb38a19 (diff)
gnu: node-irc-colors: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-irc-colors): Move package in alphabetical order. Change-Id: If30c3362a7b36be5c6e6c2e6c4284242f185f1bd
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm54
1 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index f56e07b109..5eeefb51c0 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -539,64 +539,64 @@ Node's @code{inherits} constructor that can be used in browsers, while
defaulting to Node's implementation otherwise.")
(license license:isc)))
-(define-public node-irc-colors
+(define-public node-irc
(package
- (name "node-irc-colors")
- (version "1.5.0")
+ (name "node-irc")
+ (version "0.5.2")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/fent/irc-colors.js")
+ (url "https://github.com/martynsmith/node-irc")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0q3y34rbnlc55jcakmdxkicwazyvyph9r6gaf6hi8k7wj2nfwfli"))))
+ "1ln4qfx20jbwg4cp8lp0vf27m5281z2sz16d15xd6150n26cbi4x"))))
(build-system node-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-after 'patch-dependencies 'delete-dependencies
(lambda args
- (delete-dependencies `("istanbul" "vows")))))
+ (delete-dependencies
+ `("ansi-color" "faucet" "jscs" "tape")))))
#:tests? #f))
- (home-page "https://github.com/fent/irc-colors.js")
- (synopsis "Node.js module providing color and formatting for IRC")
- (description "@code{node-irc-colors} is a Node.js module that
-allows you to easily use colored output and formatting in IRC bots.
-It contains functions for colours as well as more complex formatting
-such as rainbows.")
- (license license:expat)))
+ (inputs
+ (list node-irc-colors))
+ (home-page "https://github.com/martynsmith/node-irc")
+ (synopsis "IRC client library for Node.js")
+ (description "@code{node-irc} is an IRC client library for Node.js.
+It has functions for joining, parting, talking, and many other IRC commands.")
+ (license license:gpl3+)))
-(define-public node-irc
+(define-public node-irc-colors
(package
- (name "node-irc")
- (version "0.5.2")
+ (name "node-irc-colors")
+ (version "1.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/martynsmith/node-irc")
+ (url "https://github.com/fent/irc-colors.js")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1ln4qfx20jbwg4cp8lp0vf27m5281z2sz16d15xd6150n26cbi4x"))))
+ "0q3y34rbnlc55jcakmdxkicwazyvyph9r6gaf6hi8k7wj2nfwfli"))))
(build-system node-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-after 'patch-dependencies 'delete-dependencies
(lambda args
- (delete-dependencies
- `("ansi-color" "faucet" "jscs" "tape")))))
+ (delete-dependencies `("istanbul" "vows")))))
#:tests? #f))
- (inputs
- (list node-irc-colors))
- (home-page "https://github.com/martynsmith/node-irc")
- (synopsis "IRC client library for Node.js")
- (description "@code{node-irc} is an IRC client library for Node.js.
-It has functions for joining, parting, talking, and many other IRC commands.")
- (license license:gpl3+)))
+ (home-page "https://github.com/fent/irc-colors.js")
+ (synopsis "Node.js module providing color and formatting for IRC")
+ (description "@code{node-irc-colors} is a Node.js module that
+allows you to easily use colored output and formatting in IRC bots.
+It contains functions for colours as well as more complex formatting
+such as rainbows.")
+ (license license:expat)))
(define-public node-long-stack-traces
(package