summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 18:48:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 19:08:30 +0200
commit44156abc69fbb87614b49c509044dc168c439bac (patch)
tree118e544781d838ab37faa0552399eae82b858807 /gnu
parenta341d7c65aa3f458584ec2136be52247e2b0042f (diff)
gnu: Add texlive-mkgrkindex.
* gnu/packages/tex.scm (texlive-mkgrkindex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7aeac2099b..695c544819 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12037,6 +12037,29 @@ of TeX and one of Metafont are needed.")
;; when modified.
(license (license:fsf-free "file://tex/generic/midnight/border.tex"))))
+(define-public texlive-mkgrkindex
+ (package
+ (name "texlive-mkgrkindex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/mkgrkindex/"
+ "makeindex/mkgrkindex/"
+ "scripts/mkgrkindex/")
+ (base32
+ "0bj35wdxn0xllpqzf8lrd00b5rmyy9fws84avz3ijk4k8rvfz8gk")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "mkgrkindex")))
+ (home-page "https://ctan.org/pkg/greek-makeindex")
+ (synopsis "MakeIndex working with Greek")
+ (description
+ "MakeIndex is resolutely stuck with Latin-based alphabets, so will not
+deal with Greek indexes, unaided. This package provides a Perl script that
+will transmute the index of a Greek document in such a way that MakeIndex will
+sort the entries according to the rules of the Greek alphabet.")
+ (license license:lppl)))
+
(define-public texlive-modulus
(package
(name "texlive-modulus")