summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:29:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:34 +0200
commit497463fb299a13e48f6b348842f2c41f0fd59428 (patch)
tree3792bfb7cd5c46b94776d9c8eeb3b649b046c844 /gnu
parent6cb6915adbe693faac325bd2c47a3252aecb0542 (diff)
gnu: Add texlive-autosp.
* gnu/packages/tex.scm (texlive-autosp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e88eef1158..d858d4998a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2593,6 +2593,34 @@ package tries to put breaks at adequate places. It is suitable for
computer-generated long formulae with many terms.")
(license license:lppl1.3+)))
+(define-public texlive-autosp
+ (package
+ (name "texlive-autosp")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/autosp/"
+ "doc/man/man1/autosp.1"
+ "doc/man/man1/autosp.man1.pdf"
+ "doc/man/man1/tex2aspc.1"
+ "doc/man/man1/tex2aspc.man1.pdf")
+ (base32
+ "16szmbffp9pwzv7zq3l4yvnsfk4m7w57wib7pqpgv1v5fzhlaahs")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/autosp")
+ (synopsis
+ "Preprocessor generating note-spacing commands for MusiXTeX scores")
+ (description
+ "This program simplifies the creation of MusiXTeX scores by converting
+(non-standard) commands of the form @code{\\anotes ... \\en} into one or more
+conventional note-spacing commands, as determined by the note values
+themselves, with @code{\\sk} spacing commands inserted as necessary. The
+coding for an entire measure can be entered one part at a time, without
+concern for note-spacing changes within the part or spacing requirements of
+other parts.")
+ (license license:gpl2+)))
+
(define-public texlive-axodraw2
(package
(name "texlive-axodraw2")