summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-01-11 10:54:39 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 10:54:39 +0100
commit4b8a5205a6c2d1894be955bf934b29767e9ffd1e (patch)
tree683a8efbb81594167422085b79812f5dbfc5e4bb /gnu
parent732180015b86fe10fdbef4f3cc9a86285032f5c7 (diff)
gnu: Add python-pystitcher.
* gnu/packages/python-xyz.scm (python-pystitcher): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6e4588b39d..ac8283b1fe 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4025,6 +4025,33 @@ logic-free templating system Mustache.")
(lambda _
(invoke "python" "test_pystache.py")))))))))
+(define-public python-pystitcher
+ (package
+ (name "python-pystitcher")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/captn3m0/pystitcher")
+ (commit
+ (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "03yrzqhcsjdj5zprrk3bh5bbyqfy3vfhxra9974vmkir3m121394"))))
+ (build-system python-build-system)
+ (inputs
+ (list python-html5lib python-importlib-metadata python-markdown
+ python-pypdf3 python-validators))
+ (home-page "https://github.com/captn3m0/pystitcher")
+ (synopsis "Declaratively stitch together a PDF file from multiple sources")
+ (description
+ "This package stitches your PDF files together, generating customizable
+bookmarks using a declarative input in the form of a markdown file.")
+ (license license:expat)))
+
(define-public python-joblib
(package
(name "python-joblib")