summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2023-12-30 20:36:17 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-04 13:38:10 +0100
commit4f53dff911e80573bc77f8c76e4f101d6c3c7f46 (patch)
treefcd2114451e0d7dae6f8e6d89832576a5bab9a7f /gnu
parent8df79db37a638cc267489f40d15e69682f757de4 (diff)
gnu: python-hicexplorer: Fix build.
* gnu/packages/bioinformatics.scm (python-hicexplorer)[snippet]: Remove catchall pattern of patch version numbers in setup.py.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 41cac296fe..2ceb0190b6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16790,7 +16790,16 @@ the HiCExplorer and pyGenomeTracks packages.")
(file-name (git-file-name name version))
(sha256
(base32
- "1yavgxry38g326z10bclvdf8glmma05fxj5m73h15m1r2l9xmw3v"))))
+ "1yavgxry38g326z10bclvdf8glmma05fxj5m73h15m1r2l9xmw3v"))
+ (modules '((guix build utils)))
+ ;; setup.py is malformed. The requirements are defined using a catchall
+ ;; pattern for the patch version number. This has been fixed in version
+ ;; 3.7.3, but we cannot upgrade to this version yet, since some Guix
+ ;; packages are not new enough. (See upstream commit
+ ;; 4845c715ec7b105e938d0c2426e27d0181690bfe for the fix).
+ (snippet '(substitute* "setup.py"
+ (("\\.\\*")
+ "")))))
(build-system pyproject-build-system)
(arguments
(list