summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-01-13 13:24:23 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-12 23:31:47 +0100
commit505d7ce025b82fda87de9960a175acf2e9d86b42 (patch)
tree6ce037148088d5c00ec719039abaaec0228791a0 /gnu
parentb74e5283bbba1370429e4f1a6a7348843aa76f80 (diff)
gnu: Add dislocker.
* gnu/packages/linux.scm (dislocker): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index eb01e549ef..1d523233da 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2201,6 +2201,30 @@ The Discordian calendar was made popular by the \"Illuminatus!\" trilogy
by Robert Shea and Robert Anton Wilson.")
(license license:public-domain)))
+(define-public dislocker
+ (package
+ (name "dislocker")
+ (version "0.7.3")
+ (home-page "https://github.com/Aorimn/dislocker")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ak68s1v5dwh8y2dy5zjybmrh0pnqralmyqzis67y21m87g47h2k"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ;no test suite
+ (inputs (list fuse mbedtls-apache))
+ (synopsis "FUSE driver to read/write Windows BitLocker drives")
+ (description
+ "This package provides means to to read BitLocker encrypted
+partitions. Write functionality is also provided but check the README.")
+ (license license:gpl2+)))
+
(define-public fbset
(package
(name "fbset")