summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2016-05-31 16:31:14 -0400
committerDavid Thompson <davet@gnu.org>2016-06-03 08:54:25 -0400
commit529fe99204a8418f52d0c220430c727fc1c7a0cb (patch)
treef1224fb108bcfaeb725e8af12deaa3b58498353c /gnu
parent65b49ae702e4da3826355cb2f6c58eab97c15cbb (diff)
gnu: Add emacs-ido-ubiquitous.
* gnu/packages/emacs.scm (emacs-ido-ubiquitous): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ee875eff27..0ea317a06f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1954,3 +1954,26 @@ Importantly, it detects edge cases that ordinary ido cannot handle and either
adjusts them so ido can handle them, or else simply falls back to the standard
Emacs completion function instead.")
(license license:gpl3+)))
+
+(define-public emacs-ido-ubiquitous
+ (package
+ (name "emacs-ido-ubiquitous")
+ (version "3.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://raw.githubusercontent.com"
+ "/DarwinAwardWinner/ido-ubiquitous/v"
+ version "/ido-ubiquitous.el"))
+ (file-name (string-append "ido-ubiquitous-" version ".el"))
+ (sha256
+ (base32
+ "197ypji0fb6jsdcq40rpnknwlh3imas6s6jbsvkfm0pz9988c3q2"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ido-completing-read+" ,emacs-ido-completing-read+)))
+ (home-page "https://github.com/DarwinAwardWinner/ido-ubiquitous")
+ (synopsis "Use ido (nearly) everywhere")
+ (description
+ "Ido-ubiquitous enables ido-style completion for almost every function
+that uses the standard completion function completing-read.")
+ (license license:gpl3+)))