summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-02 09:27:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-01-04 21:48:17 +0200
commit568c12d7266c7372f04f16bcb91cbe0f88d9e70b (patch)
tree54e5b588d9701009150e641e21e4c6f4c5509abd /gnu
parent433b680dd6ac100ef6940c20b4aeb4e5c64f0e05 (diff)
gnu: openssl: Fix building on x86_64-linux-gnux32.
* gnu/packages/tls.scm (target->openssl-target): Add entry for x86_64-linux-gnux32. Change-Id: Icbbdb76134da0811b8493c55ca2d3acdb77c5883 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tls.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 75e6370c72..208a7ff640 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2019, 2021-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2021-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
@@ -429,6 +429,8 @@ OpenSSL for TARGET."
(cond
((target-x86-32? target)
"x86")
+ ((target-x32? target)
+ "x32")
((target-x86-64? target)
"x86_64")
((target-mips64el? target)