summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 14:40:45 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:01 -0400
commit579e8fd00302f72350b7f7d43cce63012a315f39 (patch)
tree46a695f03099a3eb9c4a269ee0ccd278582345f2 /gnu
parentf1d62ca272a719e32f1e8d39e40420c107780101 (diff)
gnu: docbook-xml-5: Make it the default docbook-xml.
* gnu/packages/docbook.scm (docbook-xml-5): Rename to... (docbook-xml): ... this, renaming the previous one to... (docbook-xml-4.5): ... this. (docbook2x) [inputs]: Replace docbook-xml with docbook-xml-4.5. * gnu/packages/freedesktop.scm (wayland) [native-inputs]: Likewise. * gnu/packages/freedesktop.scm (elogind): Likewise. * gnu/packages/databases.scm (postgresql-15): Likewise. * gnu/packages/documentation.scm (asciidoc): Likewise. * gnu/packages/networking.scm (iputils) [native-inputs]: Replace docbook-xml-5 with docbook-xml.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm2
-rw-r--r--gnu/packages/docbook.scm9
-rw-r--r--gnu/packages/documentation.scm2
-rw-r--r--gnu/packages/freedesktop.scm4
-rw-r--r--gnu/packages/networking.scm2
5 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 5a1f17aa7a..4cd0d61da8 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1223,7 +1223,7 @@ and high-availability (HA).")
(invoke "make" "postgres.info")
(install-file "postgres.info"
(string-append #$output "/share/info"))))))))
- (native-inputs (list docbook-xml docbook2x libxml2 perl texinfo))
+ (native-inputs (list docbook-xml-4.5 docbook2x libxml2 perl texinfo))
(inputs (list readline `(,util-linux "lib") openssl zlib))
(home-page "https://www.postgresql.org/")
(synopsis "Powerful object-relational database system")
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 8778ff1718..f8a9edd769 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -50,7 +50,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix build-system python))
-(define-public docbook-xml-5
+(define-public docbook-xml
(package
(name "docbook-xml")
(version "5.1")
@@ -97,10 +97,9 @@ suited to books and papers about computer hardware and software (though it is
by no means limited to these applications.) This package provides XML DTDs.")
(license (license:x11-style "" "See file headers."))))
-(define-public docbook-xml
+(define-public docbook-xml-4.5
(package
- (inherit docbook-xml-5)
- (name "docbook-xml")
+ (inherit docbook-xml)
(version "4.5")
(source (origin
(method url-fetch/zipbomb)
@@ -709,7 +708,7 @@ Detect the differences in markup between two SGML files.
(build-system gnu-build-system)
(inputs
`(("bash-minimal" ,bash-minimal)
- ("docbook-xml" ,docbook-xml)
+ ("docbook-xml" ,docbook-xml-4.5)
("perl" ,perl)
("perl-xml-namespacesupport" ,perl-xml-namespacesupport)
("perl-xml-parser" ,perl-xml-parser)
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 4cf3a2ca4c..27903a1ffe 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -166,7 +166,7 @@ release/xsl/current")
(native-inputs
(list autoconf))
(inputs
- (list python docbook-xml docbook-xsl libxml2 libxslt))
+ (list python docbook-xml-4.5 docbook-xsl libxml2 libxslt))
(home-page "https://asciidoc.org/")
(synopsis "Text-based document generation system")
(description
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 72d29c7b14..29121ca711 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -760,7 +760,7 @@ the freedesktop.org XDG Base Directory specification.")
(substitute* "src/login/elogind.c"
(("\"/run/elogind.pid\"") "\"/run/systemd/elogind.pid\"")))))))
(native-inputs
- `(("docbook-xml" ,docbook-xml)
+ `(("docbook-xml" ,docbook-xml-4.5)
("docbook-xml-4.2" ,docbook-xml-4.2)
("docbook-xsl" ,docbook-xsl)
("gettext" ,gettext-minimal)
@@ -1188,7 +1188,7 @@ Python.")
(native-inputs
(append
(list docbook-xml-4.2
- docbook-xml
+ docbook-xml-4.5
docbook-xsl
graphviz
doxygen
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9fbdba57a3..df3a5129cb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1609,7 +1609,7 @@ intended as a substitute for the PPPStatus and EthStatus projects.")
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)
("docbook-xsl" ,docbook-xsl)
- ("docbook-xml" ,docbook-xml-5)
+ ("docbook-xml" ,docbook-xml)
("libxml2" ,libxml2) ;for XML_CATALOG_FILES
("xsltproc" ,libxslt)))
(inputs