summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 13:43:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:42 +0100
commit584e77abd541ac5e0227639597241f3f28d139b6 (patch)
tree69e76d7131f5bb9237ce54911051afdebd9aa46e /gnu
parent087d1e16a1bd1148b7842a5857eba90ce7048a8d (diff)
gnu: restic-rest-server: Refresh package style.
* gnu/packages/backup.scm (restic-rest-server): Use G-expressions. [arguments] <#:phases>: Swap back to standard 'check phase and add 'set-tmpdir phase. [native-inputs]: Swap from propagated-inputs to native-inputs, sort alphabetically. Change-Id: I5010a2dd81b887d8ef10fa27b3ffcb228e08fade
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/backup.scm47
1 files changed, 23 insertions, 24 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 699f4cbc8f..521974f96b 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1076,30 +1076,29 @@ precious backup space.
"1nvmxc9x0mlks6yfn66fmwn50k5q83ip4g9vvb0kndzd7hwcyacy"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/restic/rest-server/cmd/rest-server"
- #:unpack-path "github.com/restic/rest-server"
- #:install-source? #f ;all we need is the binary
- #:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys . args)
- (when tests?
- ;; Unit tests seems to break with Guix' non-standard TMPDIR.
- (setenv "TMPDIR" "/tmp")
- (apply (assoc-ref %standard-phases
- 'check) args))))
- (add-after 'install 'rename-binary
- (lambda* (#:key outputs #:allow-other-keys)
- (with-directory-excursion (assoc-ref outputs "out")
- ;; "rest-server" is a bit too generic.
- (rename-file "bin/rest-server"
- "bin/restic-rest-server")))))))
- (propagated-inputs (list go-golang-org-x-crypto
- go-github-com-spf13-cobra
- go-github-com-prometheus-client-golang
- go-github-com-miolini-datacounter
- go-github-com-minio-sha256-simd
- go-github-com-gorilla-handlers
- go-github-com-coreos-go-systemd-activation))
+ (list
+ #:install-source? #f
+ #:import-path "github.com/restic/rest-server/cmd/rest-server"
+ #:unpack-path "github.com/restic/rest-server"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Unit tests seems to break with Guix' non-standard TMPDIR.
+ (add-before 'check 'set-tmpdir
+ (lambda _
+ (setenv "TMPDIR" "/tmp")))
+ (add-after 'install 'rename-binary
+ (lambda _
+ (with-directory-excursion #$output
+ ;; "rest-server" is a bit too generic.
+ (rename-file "bin/rest-server"
+ "bin/restic-rest-server")))))))
+ (native-inputs (list go-github-com-coreos-go-systemd-activation
+ go-github-com-gorilla-handlers
+ go-github-com-minio-sha256-simd
+ go-github-com-miolini-datacounter
+ go-github-com-prometheus-client-golang
+ go-github-com-spf13-cobra
+ go-golang-org-x-crypto))
(home-page "https://github.com/restic/rest-server")
(synopsis "Restic REST server")
(description